Layered Clothing Texture Not Loading In Game

Reproduction Steps

In this case I have no idea why it is that my newest layered clothing item ( Zombie Attack! Suit - Roblox ) is not loading its texture in game. I uploaded it like every other LC item I’ve created, the textures were in a SurfaceAppearance and were approved before I submit them to the site, and in the avatar shop the texture appears–but when they load into game with it it’s just grey.

Expected Behavior

Texture should load in game as well as in the avatar shop.

Actual Behavior

When you wear the item in game, the surface appearance doesn’t seem to load. Interestingly it does load if you play solo in studio.


The only work around I could attempt would be to reupload it. I haven’t tried this since we only get a certain number of slots each month and I don’t want to waste a lot (and an upload fee) on reuploading it, not to mention having it lose the momentum of the sales it’s already had.

Issue Area: Catalog Assets
Issue Type: Display
Impact: High
Frequency: Very Rarely
Date First Experienced: 2022-10-14 13:10:00 (-07:00)
A private message is associated with this bug report


Hello, we’ve been looking into this issue and for some reason this falls into pathological case for our backend processing. We have made a fix for this in the next release. Sorry for the inconvenience and thank you again for reporting this issue, we really appreciate it.


Thanks for the fix! I figured it had to be something wonky on the back end. I’ll let you know if I run into any more issues.

1 Like