Levitating on a blender mesh

Hello, im gpm231 and i am having some problems with meshes from blender.

Here are some screenshots of the issue:


Hope there is a solution!
If you want to see the map you can enter this game: https://www.roblox.com/games/2926835835/gpm231s-portfolio
Thanks!

2 Likes

Check that there is nothing superfluous in the model, I can not, I can not get there, one thing interferes with the teleport. I can say that you need to check whether there is nothing superfluous in your model, check on a blender or just check, I can’t say anything more

1 Like

You can now teleport to the map, there was an issue with a forcefield

I have several ways

  1. re-export only via fbx
  2. put on your model above
  3. learn something about teleport

@WiryReally sorry but neither on your posts are helpful.


Edit: See @Chager’s post for an actual solution, I’m just explaining how to see it visually. Thank you Chager! :slight_smile:


@gpm231 while in Studio, go to Settings


When you’re there, click the Physics tab, and check Show Decomposition Geometry

Now, either save/reload your Studio place, or duplicate the MeshPart to view the decomp geo.

Before duplicating


After duplicating

6 Likes

Of course, you understand more in Roblox studio
And I have a question. And how will this help?

To add on to this a bit - when you upload a mesh, the mesh importer automatically creates a collision model for the mesh, which dictates how the object will collide with other objects in the game world. The more complex the mesh is, the more likely it is that you’ll have an “inaccurate” hitbox as shown in the OP. The solution in this case is to either a) create a custom hitbox for the model out of parts (with the transparency property of each set to 1) or b) create a less detailed model. It would be really great if we could create custom collision models in blender, but unfortunately we can’t (yet?)

2 Likes

yes, but I said that it is necessary to check that there is nothing superfluous in the model. Like a hitbox that just holds on to the point

I seriously doubt that our friend @gpm231 purposely added invisible parts to produce this result, only to make a post asking how to fix it…

1 Like

Well, I had such a problem when I did my model in a blender
I was only helped by ctrl-z. I just clicked when I saw etto without understanding.
and she’s a little who will see it

Thanks! I will see what i can do by following your advice.

I really appreciate that you explained me this, thanks!

1 Like

While going all the way into settings, ticking “Show Decomposition Geometry”, and duplicating the MeshPart is an option, I’d suggest using CloneTrooper1019’s Show Decomposition Geometry Plugin, which adds a convinient button in the Plugins tab and doesn’t require duplicating any MeshParts or reloading the place to view the collision.

Anyhoo, to add a potential solution to gpm231’s issue, there is one way to create accurate collision. An .obj importing plugin!

These kinds of plugins are not ones to use excessively though, purely because of how they work. Since Roblox doesn’t allow us to just create a singular triangle with three points anywhere in space, polygons are made with two wedges side by side.

This kind of plugin is good if you’re using it on a mesh intended to be a large chunk of your map’s terrain, but if the alternatives of using simpler meshes or creating your own hitbox manually fit the situation better, I’d go with those.

2 Likes

I’m confused on this, what should we do after?