LIGHTING completely missing from my game in CLIENT ONLY

I am making a 2-D platformer game, but there is a bug ruining my game. :confused: The lighting is completely missing from one of the Places in my game. Just that one Place. And it’s only missing in the client. When I switch to the server camera, the lighting is there. There are also no shadows at all in that Place. The same thing happened when I played the game through Roblox.

At first I suspected it might have been caused by this Albert Einstein robot character I put together, because I didn’t put him together correctly and I noticed that humanoids can cause lighting glitches when they are messed with. I tried deleting him but it didn’t change anything so I brought him back. Next, I wanted to make a new group, so I copied and pasted this game to the new group. I tried not bringing the Einstein robot with the game but the lighting glitch was there anyway. So it must be attached to something else in the game. :thinking:
I tried going back a few versions but it turned out the glitch had been there for too many versions, and I just didn’t notice the problem for a long time.
Any help is appreciated! :slightly_smiling_face:

If GlobalShadows isn’t checked in the property, then you shouldn’t be expecting it. If this isn’t the case, then it’s probably the Technology property within the Lighting. Try switching that around in the Lighting properties to see if that results into anything.


Ok, I’ll try that. Also, global shadows is checked. Thanks.

I changed the lighting technology and apparently only the lighting type “future” works, but anyway, the lighting is now fixed. Thanks again!

Be advised that the “Future” technology type only works in-studio as of right now.

Roblox has not shipped this yet, so when player’s visit your game, it won’t have the effect that you’re intending it to have.

1 Like

I didn’t know that so thanks for telling me. I guess I still have a problem?

1 Like