Lights only load in when player is distant (future lighting)

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    I am looking for my in-game lights to remain constant no matter where I am (apart from un-loading as I travel far)

  2. What is the issue? Include enough details if possible!
    The issue is that as I move towards the light source, the light becomes covered in some shadow that isn’t my player’s. I’m not sure what’s causing this but I suspect it has to do with the lighting tech I use.

I’ve tried switching from Future lighting to Shadow map and it works great, however I was just wondering why it happens in future at all since it’s supposed to be a new lighting option, and I think I prefer it for my game.

Here’s a video of my problems:

Here’s my current lighting setup:

Changing to shadowmap resolves the issue, however certain interiors in my game loose it’s appeal so if there’s a way to fix this it’d be highly appreciated.

SOLVED: Make sure the part that the lighting element is within has cast shadow diabled

4 Likes

that’s exactly it. It’s a new lighting option released recently, there are bound to be bugs and issues scattered here and there. It is likely a bug.

However, maybe it’s an issue to do with something in studio lighting.
Under Lighting, try changing some of the settings around and see if that fixes anything. If not, continue to report it as a bug.

2 Likes

Try giving this a read, it might help you resolve some of the issue hopefully:

2 Likes

I know it’s been a super long while but how would I go about bug reporting?

Are you sure this isn’t the way you have built the lighting pole? Meaning where you have placed the point lights…

Edit: have u tried to test, by isolating one light pole to an empty baseplate and trying to replicate the issue.

1 Like

Unfortunately until they finally update the DevForum trust levelling system thing, you gotta be a ‘Regular’ to sent bug reports.

1 Like

I appreciate that suggestion because it actually led me to test and I found out what the issue was. The part that was housing the point light had CastShadow enabled which was the issue at hand. Thank you!

1 Like