LoadAsset should have permissions to insert any free model from the command bar

I think this is related to a recent update to InsertService but I’m not sure when exactly this change happened. I frequently tried out models by using the website search to find them and then inserting them using InsertService. Trying this now outputs the error “Asset is not trusted for this place”. Plugins and the command bar should be able to insert any free model, the restriction that the asset must be owned by the place creator should only apply to live games.

Steps to reproduce:
Open a new place in studio.
Run the following in the command bar:
The asset id can be any free model and you will still get the following error:
HTTP 403 (HTTP/1.1 403 Asset is not trusted for this place).


Yes please!

In the meanwhile, you can use this:

_G.insert = function(id) 
	local items = game:GetObjects("http://www.roblox.com/asset/?id="..id)
	for _,v in next,items do 
		v.Parent = #game.Selection:Get() == 1 and game.Selection:Get()[1] or workspace

I have that registered in _G by a plugin so whenever I want to try something out I can just enter “_G.insert(68997620)” into the command bar.