Loading A Image ID Seems To Be Impossible

Hello. I Still Have This Problem From A Few Months Ago The Problem Is Its IMPOSSIBLE to Load A Image With Script I Tried To Set The Image ID on a texture with rbxassetid://(Image ID here) but didn’t work then I tried to load the asset but it loads the creator assets only then I tried to subtract the image ID - 1 until getting product info finds the owner of that image ID which is not nil but still NOT and I have NO IDEA! how to fix it (please help and sorry for bad grammar)


Please can you show the script you currently have so i can look into the issue?


--function imagetoasset(image)

-- local info = game:GetService("InsertService"):LoadAsset(image)

-- info.Parent = game.ServerScriptService

-- info:FindFirstChildOfClass("Decal").Parent = script.Parent.Parent



local isnull = true

local decalID = 5595271699


decalID = decalID - 1

local curId = game:GetService("MarketplaceService"):GetProductInfo(decalID)

if curId.Created ~= "null" then -- This id exists.

print(curId.Name) -- Print the name of the sound.

isnull = false

decalID = decalID - 1

script.Parent.Texture = "rbxassetid://"..decalID


until isnull == false

--local curId = game:GetService("MarketplaceService"):GetProductInfo()

--if curId.Created ~= "null" then -- This id exists.

-- print(curId.Name) -- Print the name of the sound.


Can you confirm the image you are trying to use,

It seems you are changing the ID for no reason

Well im trying random images

Right now I’m testing with:

(7) BRUH! - Roblox
(7) bruh - Roblox
(7) bruh - Roblox

Thats weird, its not working maybe theres an issue with the image on ROBLOX

Well the line that is decalID = decalID - 1 between isnull = false and script.Parent.Texture = “rbxassetid://”…decalID when I removed it didn’t work but when I added that it worked with the first one and not with others

What are you doing DecalID - 1 for?

And also f3x building tool can insert image ID and when i tried to load f3x building tool from HD admin it gave me error i have no idea

In another topic some where somebody said subtract the id until you get a correct one so i tried that

Here’s 3 things you could try:

  • Only using the image ID. Example: image.Image = 123456789
  • Check if the image you’re using is approved by Roblox and is not archived, therefore it can be used in games.
  • Make a new image instance manually in studio and add the ID to that, setting the visibility to true and false when trying to change the ID. Shortly said, instead of changing ID, set image visibility with the ID.
1 Like

Well i tried but still not working(not showing)

Images dont nescessarily have their true image 1 id below. You can create a decal in studio, paste yo-ur id in as the texture and studio will automatically change it to the ID you need to use which you can then copy n paste

Well is there a way to do it with a script without entering Roblox studio I mean I want players to go to the library and find an image id then paste it and then it will change because the F3X building tool has this ability

There very most likely is, try doing some google searches or searching the devforums. I unfortunately dont have an answer of the top of my head rn

I searched a lot but I still got no solution

It unfortunately doesnt look like there’s a built in way to do it through scripts.
You can try verifying image id by looping all id’s subtracting 1 everytime. But thats not very efficient.
Here is a topic that is relevant to your concern.