Loading players appearance onto a StarterCharacter

So, I wanted to load the player’s appearance on a StarterCharacter but I met some unexpected difficulties, I wanted to use HumanoidDescription but nothing seem to work, whenever I use ApplyDescription the joints break

The code I used

-- Services --

local Players = game.Players

-- Functions --

local function OnPlayerAdded(Player:Player)

	local HumanoidDescription = Players:GetHumanoidDescriptionFromUserId(Player.UserId)

	Player:LoadCharacter()

	local Character:Model = Player.Character or Player.CharacterAdded:Wait()
	local Humanoid = Character:WaitForChild('Humanoid')

	Humanoid:ApplyDescription(HumanoidDescription)

end

-- Connections --

Players.PlayerAdded:Connect(OnPlayerAdded)

Thank you

1 Like

This is how I have mine setup

game.Players.PlayerAdded:Connect(function(player)
   player.CharacterAdded:Connect(function(character)
      repeat task.wait() until character:FindFirstChild("Humanoid")
      local humanoid = character:FindFirstChild("Humanoid")
      local appearance = game.Players:GetHumanoidDescriptionFromUserId(player.UserId)
      humanoid:ApplyDescription(appearance)
   end)
end)

Thanks for the quick response, I tried ur script but i still play as the StarterCharacter, maybe there’s something wrong with my StarterCharacter model?

1 Like

Out of curiosity, why are you doing this manually? A player’s character is automatically loaded with their avatar already and is defaulted to their avatar each time they respawn, unless specified otherwise.

There’s no need to apply the description manually, unless I’m missing something.

1 Like

He is probably has a custom character of some sort and is trying to apply the humanoid descriptiion because I know in my case my startercharacter still has most of the same limbs a regular character has but like it has a few other things so I apply the description of the player who joined

My heirachy
image

1 Like

It’s for testing purposes, also sometimes I can’t even save my game because of connection issues and for the same reason I can’t change my game settings

1 Like

Does it work for you tho, the only difference I noticed is that I use r6
RobloxStudioBeta_T0aEPZ8qRn

1 Like

Yeah im using r6 aswell and it works perfectly for me

1 Like

Do you also store the script in ServerScriptService, or maybe is it because i can’t save the game and change settings?

Yeah the script I showed you is in serverscriptservice

This is really strange, like i think i did everything like you but it still doesn’t work

Are you getting any errors in the output, was that your whole script maybe you have something conflicting somewhere else

I created a new place and did everything as u said, i get no errors in output, do u mind checking the project file?
Avatar Test.rbxl (57.7 KB)

1 Like

Hmm yeah when i opened the place up looks like you had the script in ServerStorage, I moved it out of server storage and put in my code from before and it seems to work, although the body back attachment isnt in the correct place though but thats just an attachment position problem

Avatar Test.rbxl (57.6 KB)

1 Like

Man Im so stupid how did I not see that it was in ServerStorage, sorry for wasting your time, thank you so much

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.