Loading screen getting stuck after ContentProvider "invalid stoll argument"

As explained in the title, I’m wanting to resolve an error that is appearing whenever I try to play my experience, and causes the loading screen to get stuck indefinitely.

The experience uses a relatively simple loading screen, which is handled by the below logic:

ContentProvider:PreloadAsync(hall:GetDescendants(), function (...)
	n += 1

	ContentProvider.RequestQueueSize == 0

Normally, after this a short transition is performed and the loading screen is destroyed.

This has always worked, however since today, whenever playing the experience in the Roblox Player (this doesn’t happen in Studio), the console throws the following error (which is not tied to any script):

ContentProvider callback exception: invalid stoll argument

And the loading screen gets stuck indefinitely. Through debugging, I have found that the code never continues past the PreloadAsync() loop.

I haven’t managed to find any posts about this same error on the forums.
I have attempted debugging the names of all objects that are preloaded, assuming an error would occur on a specific asset, but this did not happen, and instead the preloading stopped at a seemingly random point without any further errors.
I have also attempted temporarily deleting the asset preloaded directly prior to the error being printed, which also did not help.

If anybody has any idea why this error is occuring, or/and how to fix it, any help would be greatly appreciated, thanks!

stoll is an internal function roblox is using to convert a string into a number. It’s a mistake on their part that you’re seeing an error mentioning it, but it may still be caused by something you’re doing. Or its a new roblox bug.

The code you posted has syntax errors though, is this exactly the code you’re running? For instance it’s missing an ending parenthesis. I think you’ll need to post your complete code for further help.

Edit: just for curiosity’s sake, here’s the C++ function I’m guessing it’s talking about: stoll - C++ Reference

Thanks for the info, yeah looking for a bit I ended up on that page you linked, though of course like you said that’s a Roblox internal function.
I feel that it may be a new Roblox bug, as the loading screen has always worked before this (no changes were made the the loading screen or its code since then), however I haven’t seen this on any other experiences.

As for the syntax errors that’d my bad, I double checked and the end does have ending parentheses, I just missed them when putting the code up on here, I’ll edit that.
No other code is relevant though, just some variable declaration before (this is done without issue) and the loading screen is destroyed after, though as mentioned on the post, no code following the PreloadAsync() function is ran (no errors/warns)

You should post the entirety of your code, just to be sure.