Local surfaceguis cannot be clicked unless they are directly parented to PlayerGui

We have the menus in our game all 3D that are on surfaceguis
In the process of trying to convert it over to console we ran into this

-There’s a folder with all the different surfaceguis that make up the inventory and shop sitting in the playergui
-Buttons in these surfaceguis don’t do anything when clicked with a controller
-Tried to move one of the surfaceguis out of said folder and into the players playergui, suddenly now it’s able to be clicked
-All the surfaceguis can be clicked normally with a m+kb setup, controller doesn’t work

Image for reference how I have it set up
image

4 Likes

It’s because it’s in a folder. If you put all those items in a (1,0,1,0) transparent frame it will work

I originally had everything parented to a surfacegui in playergui
then tried a normal screengui as well
frame doesn’t fix it
it completely breaks the ui and also no longer lets me select buttons even though everything is still set properly