Locating Inappropriate Model In my Experience

I am looking to remove a Unknown Inappropriate model in my game that cause a 3 day ban in my account and permanent suspension on my experience.

I have spent several months building and scripting this experience so I do not want to lose my game. I was able to retrieve all the models in my game, My game has several Free models, an example would be a Zed tycoon script. Roblox Studio is preventing me from uploading or saving any changes in my game because it still contains the Inappropriate model.

My problem is finding that Inappropriate Model. Roblox has given very few details about it. The best information I got is the Moderation message which stated (Adult model replicated using require id found in your game.). I do not think I understand fully what that means.

Solutions I have come up with is manually checking every single model, script, and sound in my game. My game has over 300 Scripts and Probably at least 500 Models and I was unsuccessful Locating anything Inappropriate. I have also Sent appeals to Roblox Moderation staff stating if the suspension was a mistake or if they can give me any details about the model. Moderators messages are very limited in details, only stating my experience contains a Inappropriate model, And they will not adjust any moderation action. I even tried separating my game into four pieces, seeing which piece is unsavable in Roblox studio. All of these methods were unsuccessful. Now when I log on studio and start my experience, I have limited time to do hardly anything before I get an error which closes Roblox studio.

Anyone have any tips or tricks how to solve this problem?

1 Like

Whenever you take a free model you should always delete all the scripts from it you dont trust. You can locate the script that is using require() by going into View > Find All / Replace All and searching for require which will show you all the scripts which use it. require() can be used to require scripts outside of your game which can load unwanted assets so its always good to check free models for any scripts and delete them.


When I checked every script in my game, I did find a few scripts I did not need. After I deleted them I tried saving my game but studio again prevented me from saving it. I’ll still try to see if your advice will work. (Found no scripts in the Find All / Replace All searchbox using require( ).)

I believe you cant save any changes to a place that has been moderated, so you will have to create a new place.

When I transfer my models to another place, that new place becomes censored and prevents me from saving that place, then I start receiving errors which later kicks me out.

It could be that you just cant use anything from a moderated place but im not 100% sure about that.

Check if you have any old game-saved files or old auto-save files. They may be safe before the moderated content was added, or go through the painful task of deleting models/scripts from free models until you find it.

That is what I am trying to do now, but now even the earliest versions of my game are being moderated. I guess I am closing up on it. I THINK it’s not a script but I am still cannot be sure.

The errors I received contains this: Incident ID: 7265110997922490441
It said “If you continue to encounter this error, please report it on the [Developer Forum]”, So here it is.

Im pretty sure your game is still backdoored, as @realmile said, use “Find All / Replace All”, but search for getfenv, require, loadstring. Make sure you check every require that is using asset id.

1 Like

Everything in my game has been able to save (such as the map and vehicles) except for my tycoons. This should narrow the search; however, the Tycoons are the central point of the game with 300 scripts in that model. I will try to follow your advice on looking for everything that is using a asset id. Currently I have found none so far, I’m not much of a scripter so If there are any more search words or tips you can give, it will help. Thanks for the advice, guys.