Login no longer marshalled from website to Studio

Reproduction Steps

1. Log out of the website and from in Studio.
2. Login to the website.
3. Click the “create experience” link from Create page
4. This opens an instance of Studio where I am not logged in

Expected Behavior

I expect my login to be marshalled from the website to Studio, so I don’t have to login twice. This is especially annoying with 2 factor auth.

Actual Behavior

I have to login twice
I have to login twice

Issue Area: Studio
Issue Type: Other
Impact: High
Frequency: Constantly
Date First Experienced: 2023-01-30 00:01:00 (-08:00)

5 Likes

When Studio launches, are you not getting this alert?

image

Hitting “Login via Browser” should take you back through to the browser where you are already authenticated and re-launches an authenticated Studio. No additional 2FA needed.

I don’t think so. I don’t think I got it last time, maybe it doesn’t appear if Studio just also did an update?

I do get it now though. It doesn’t work, however.

Here are some steps I just did to confirm:

  1. Log out of Studio in upper right corner
  2. Close Studio
  3. Be logged into website
  4. Click “create experience”
  5. Now I get that dialog
  6. Click “Login via Browser”
  7. Studio now spins forever.
  8. Click “Retry login with Browser” does nothing

This is with Brave browser (don’t know if this matters?)

2 Likes

Thanks for the follow up and additional info! I’ll see what I can find out from the devs with this.

Out of curiosity: is Brave set as your system default browser? Could you try the same steps but with Edge or Chrome set as the default?

2 Likes

@Shedletsky quick feedback from the devs is they believe it is related to Brave. On a quick test with Brave, it looks like Studio is trying to open Chrome… so we’ll take a look at fixing this going forward. Thanks again for the information and report!

2 Likes

A fix for this went out this week and our team can no longer reproduce it. Can you confirm?