Long "Unhandled Promise Rejection" warning gets spammed in my playtest outputs

Reproduction Steps
This warning prints in my output every time I run a playtest in studio:

My computer:

This happens both on play solo tests, and on player + server tests in the client-side output.

Edit: This also happens in live servers of my places

I develop with an “unreliable and slow internet connection”, if that should matter at all.

Another user posted about this: Unhandled promise rejection

Apparently publishing the game fixed the issue for them? For me, I see this both in (non-team-create) published games and in published/saved team create games.

Expected Behavior
This should fail silently instead of spamming the output every playtest.

why is there a character limit for this part of the bug report wizard

Actual Behavior
A very long warning appears in the console for a core script that I shouldn’t know about.

Issue Area: Studio
Issue Type: Display
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2021-09-15 00:09:00 (-06:00)
Date Last Experienced: 2021-09-16 00:09:00 (-06:00)
A private message is associated with this bug report

Edit: This issue seems to be caused by the core scripts not handling empty descriptions correctly, as discovered by @GolgiToad, so adding a description to your place seems to be a functional workaround to this issue.


Do you have Social Service’s Invite feature in your game? Because, similar thing happens if you use it.

I do, but this warning appears immediately whenever I join the game on my client, regardless of whether I actually send out invites.

I squashed this promise error…

Read it closely…

(drum roll)

Your game doesnt have a description and or name…

this has also happened to me but it hasn’t effect anything on my game

I can reproduce it on my windows PC, and my pc specs are overkill so i dont think that can be the issue.

1 Like

Check your game settings. If your description is empty, put something in. I havent seen the error since.

1 Like

Hmmm, @DataBrain you should mark this as a workaround, this stops happening after u put a description.

Looks like adding a description to my places worked in getting rid of the error.

Regardless, this is a bug that roblox should fix on their end.

@anirudh851 already one step ahead of you!


Also experiencing this bug, place with no description

Thanks for the report, we will turn off the change that caused this issue on Monday.


This issue should be resolved now


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.