Lost saved studio data (Save Failure: http 500 internal server error)

  1. What do you want to achieve?
    I want to return my work in progress in studio. I am working on my game remotely from another experience place in studio so i can keep working and publish a bigger update without worrying about teamcreate auto publishing my game. Now i also found out that i am no longer able to publish nor save the game

  1. What is the issue?
    My Studio progress of the past 6 days has been gone even though i am 100% sure i have saved & Published the place multiple times before exiting studio. Today when i opened my place i found out that the latest version is (17 may 2024)

I even made sure that it got saved because this is not the first time happening to me i left studio and rejoined the experience via studio and my changes were there until i joined the studio 5 days later to see all progress gone.

I am repeating again i am 100% sure that i saved and published multiple times before exiting and i have even confirmed for myself that the stuff was saved to the cloud by closing studio and starting studio again everything was there saved on cloud 20/21 may


  1. What solutions have you tried so far?
    I tried to revert to an older version but these older versions don’t contain the updates i made they are even older version of the version i am in now.

I tried restarting studio and also tried to open the original game place where i also have saved these changes.

It seems like this is a Roblox sided issue and i want you guys to inform me if this is going to be fixed otherwise i can’t work on studio if roblox servers keep deleting my Cloud saved data!!!

This has happened to another friend of mine aswell 2 weeks ago he randomly lost progress on his studio place.

It seems to happen on places where Teamcreate is enabled!

UPDATE !!!

It happened again and now i am getting this error everytime i try to save my experience!

image

Hi, you can reduce the auto-save interval in the studio settings. This way you will have a better chance of saving it. Alternatively, check if you have an autosave file on your disk or reinstall your Studio. Perhaps these tips are not so effective, if so, then contact Roblox technical support with this issue, because it really sounds like a data problem on the part of Roblox.

Yes auto saves are enabled,

The problem is i am not able to save or publish whenever team create is enabled once i do i get the error in the image provided.

I seem to be having the same issue with just one of our Team Creates. It was saving fine and suddenly about a week ago it stopped saving and we’ve been losing all the changes made by any team members where the console Output just lists 500 errors from Roblox for save attempts. I think this needs to instead be reported as a bug. We tried saving the place as a new Team Create under a different person and the problem follows the place.

I have contacted Roblox and send a video of the issue,
They send me this link which didn’t solve the issue…

For me we discovered it was the size of the terrain and the large amounts of water far below it and just outside its extents.

Once we removed all the water, the size of the place (for when you download a copy to save) dropped from 150KB to 45KB. After which our auto-saves started to work once again.

So best I can tell is that they seem to have a limit with either the size of the place or the time it takes to transmit to their cloud. Either way, it’s pretty odd that just a large region of water that extended some past the 16384 studs of terrain size for x and z axis, and went below it like 1000 studs would cause it to fail saves, or that evaporating all the water would manage to remove 100KB of size and allow it to save again.

1 Like