Low FPS in Roblox Studio

I am trying to resolve my issue of only being able to reach a very low FPS in Roblox Studio, specifically on a bigger game, the other developers (with worse specs than my laptop) are able to work on the game at about ~40 fps, while I am unable to reach more than around 20.

I am unable to reach a framerate that I consider usable (30 ish), with a max of around 20.
image (this is what it often is, with it occasionally jumping up to 20 for a second or two)

I have tried every graphics mode, and even with the graphics levels all at 01, I can only reach a peak of 20fps, where the camera is still jittery and hard to use. I have also tried updating all my drivers, which have not helped.

I am running a 11th Gen Intel Core i7-11800H at 2.30GHz, with 32GB of ram. I have integrated graphics + Nvidia GeForce RTX 3060 GPU for my laptop.

maybe go to settings and turn down some settings, that might help.
or -i see you have enough memory-

maybe try reinstalling studio with the most recent launcher (remove ALL FILES from studio and then reinstall by going to the roblox website and installing latest launcher)

a complete reinstall will clear any history, log files and plugin memory (everything gets reset back to normal)

ill try reinstalling it right now

1 Like

just tried that - didn’t work (got a bit distracted, sorry for long reply time)

How long has it been like this, like is it new or a constantly recurring issue?
If it’s new then you should check if you have the latest drivers, or if you changed any settings around the time it started happening. Even physical damage, maybe you just need to physically clean up all the dust.

If none of these do anything there are a few troubleshooters online, as well as benchmarking tools. For example, is it only in Studio or some other programs, or everything?

Could also try to revert to a older version of Roblox Studio (if you’re able to), see if it’s a Studio issue. Is it all games or just this one.

I haven’t really been in big games in about 3 months (usually making smaller stuff that sometimes ends up in a big project) so its been happening within the last three months.

I’ve already checked drivers. Can try clean dust tomorrow, afaik it only happens in studio and nowhere else. Will try look for some troubleshooters.

I’ll also look for some older studio versions to see if that helps.

Tried clearing dust - didn’t help, and the only older Roblox versions I could find were from some sketchy sites, will take another look later though.

I should also add, I can get a perfectly fine framerate in playtest or playing the game through the Roblox Player.

wasn’t able to find any older studio versions

Can’t recommend any specific sites as I have no idea if they are malicious or not, but just giving it a quick search and I found many results. You could always scan the file on VirusTotal or something of the sort to check if it’s safe or not.