Macbook Air Roblox Studio graphics problem

So I own a M1 Macbook Air with 8GB of RAM, 254 GB of memory.
image
And when I run Roblox studios on this, there isn’t any lag, however, the graphics are really bad. I have mine set to level 21 and it still makes my parts look pixilated.

Reference:

There are also other problems which are listed in my other post about how the decals and textures go blury whenever I test in studios.
Before testing:


After testing:

I don’t know if this is a ROBLOX issue or my issue. Please let me know if you have the same problem and if so, is there a fix to this? It’s not really too disturbing, but whenever I take screenshots of my builds, they look like I only made it out of 5 parts.

3 Likes

When you playtest the graphics goes to the graphics settings you have in game, so if you have, let’s say, a graphics of 5 in game then it will apply to studio as well. Try using the escape menu to bring up the graphics.

1 Like

Ok, thanks. I’ll try it out. Though I’m probably 100% sure that I always have it to the max graphics.

Ok, I tested it out and it was already set to graphics 10, as I thought. And here was the outcome:

The premium logo is blurred out, my building looks really bad and my avatar seems to have colorful outlines.

2 Likes

The colorful outlines on your pants are part of your clothes. Png

2 Likes

Yes, I understand. But when testing for example a baseplate, there is none of the outlines. And you can see that the build in the background are really blurred out and pixilated.

I don’t fully understand on how this works, I had a macbook air as well and I didn’t experience these issues. so I would recommend just uninstalling roblox studio then reinstalling it.

1 Like

I did that around 3 times, but still not fixed.

Have you tried copying your game to a new game place?

(File > Publish To Roblox As… > Create new game)

Perhaps you can try deleting this folder? This might fix your problem.
Captura de Pantalla 2020-06-30 a la(s) 10.48.49
Keep in mind this will reset your preferences. Also, you could try reinstalling ROBLOX studio. This might be helpful too. Good luck, I hope you fix your problem eventually! :slight_smile:

I’ve tested it out, and here was the result:

  1. The pixilated bricks are I believe gone

  2. However, the materials do blur still.

1 Like

Do you have ‘Metal’ selected in ROBLOX Studio’s rendering settings? I’m not sure if this will help but it’s worth a try.

This is API Rendering problem or Compressed texture files

I’m not sure what is the main issue but i should say that you should use Graphics Mode called “Metal” pre installed for MacOS and MacBook

if it contains OpenGL or Vulkan (I’ve never use MacOS before) then try those but i don’t suggest going Vulkan because Macbook might face some issue with it

1 Like