Making the topbar visible isn't working

I’d like to make it so that the Topbar is not transparent (so it’s black and you can’t see through it) and is that way when my custom loading screen appears when you join.

So, I’ve tried the normal way by putting a local script inside of the startergui, containing this code:

local Player = game:GetService("Players").LocalPlayer
local PlayerGui = Player:WaitForChild("PlayerGui")

But, nothing is happening. No errors, either.

I’ve tried disabling removing the default loading screen, putting that script in replicated first, and neither of those has worked.

That is deprecated due to the new menu being added to Roblox and won’t be used for a long time now.

@0therw0rldly If you want to add something similar to the old topbar with the transparency and stuff, maybe add a UI to it and customize it, works for some users. :eyes:

Announcement thread.

1 Like

Hm, how can I make it so it’s not transparent, then? Other games still have visible topbars.

*How can I make a ui in the position that the topbar was in? It looks weird when the loading UI is not covering the entire screen and there’s an space above it that you can see through.

You can just add a frame and then mess with colors and transparency, make the position of it go up, and test out the game until it is like the original topbar.

Size: (1, 0) (0, 50 or 75)
Position: (0, 0) (0, 30-50)

Yes, it is weird when the loading screen isn’t covering the entire screen due to the CoreGui for the past years.

No need to do that
Just click on the screen gui and enable “IgnoreGuiInset”. That will cause it to ignore the offset caused by the topbar.