Marketplace API isn't working

The External v2 Marketplace API query parameters aren’t working, even the example that the documentation gives doesn’t work and returns the incorrect data for the given query parameters.

Documentation Example that also doesn’t work.



This has always been a problem with the catalog v2 search API and it’s never been fixed yet.


What do you mean by “doesn’t work”? It works fine for me, so I don’t know if you’re experiencing problems of it not returning anything, showing incorrect data, etc.

doesn’t, it’s showing incorrect data for the parameters.

1 Like

Apologies for necro bumping. This is a bug that is still occuring. I haven’t found any bug reports on this.

@DiamondRoPlayz is right. The example given in the documentation intends on returning a list of result for the ‘Gears’ filter, however it returns results for the ‘All’ filter.

This issue is stopping me from specifically targeting Limiteds/Limited Uniques as I’m unable to specifically filter for them.

I hope this will get fixed in the near future, this API would be very useful if it worked as intended.

1 Like

Have you tried sending a bug report?

I don’t have permissions to post in the #bug-reports:engine-bugs channel unfortunately.

1 Like

Message @Bug-Support if you can’t post in #bug-reports.