Massive FPS drop to 30fps when moving any part

Whenever I try to move any part in my game the fps almost instantly drops to 30, I disabled every plugin - didn’t do anything. If I unlock the fps and I get like 600 fps it still drops to 30 when moving parts, my game only has like 50 parts right now.


I may be overthinking it, but it is possibly the fault of the weapon’s number of faces/triangles it has.

Check the model’s wireframe if it’s not too many triangles, if it’s entirely just full colored model and not simply a little number of them, then I think I see the problem.

1 Like

it also happens with very low amounts of tris (just basic cubes) weapon is ~9k tris

Shot in the dark but any chance you have adaptive sync (G-Sync, AMD FreeSync…) on? There’s an awful lag issue in studio when those are enabled so this may or may not be contributing to your issue?

Have you tried seeing if it’s one of your plugins by running studio w/o any plugins?

Is studio primarily using your CPU or GPU when this happens? You can check by opening task manager (CTRL+SHIFT+ESC)

no sync stuff enabled, i have tried with all plugins disabled - nothing

1 Like

neither gpu or cpu activity goes up