Memory Dumps Don't Escape Characters in Properties

Micro-profiler memory dumps from the frame dumps do not properly escape characters within the names of BaseScripts when they show up within the memory dump.

This issue has always occurred and has happened to me before. This slows the process of debugging memory dumps on some places I work on as it requires me to manually edit the file to fix the issue with the strings, which can take around a few minutes or so depending on how much instances I need to fix.

This issue can also happen on the server micro-profiler dumps if a server script has a escaped character within the name. In other words, it can be reproduced on both the client micro-profiler and server micro-profiler.

Expected Behavior:
Properly escape strings on properties (.Name) so the micro-profiler dumps may be properly utilized.

Repro Place:
(The example game is also open-source, you can open it in Roblox Studio.)
Example Game
This can be reproduced by simply creating a new baseplate and naming a BaseScript with any of the escape characters: \t, \n, etc. After which make the script pop up in the memory analyzer by having it run as the memory dumps.

Other cases:
This happens on a few projects I work on, here is another example:
Game Link

Gyazo MP4
Join either of the listed games above, turn on the micro-profiler and dump any amount of frames. You can also create a brand new baseplate and name a BaseScript with a escaped character yourself.

Attached Pictures & Dumps:

Source Example of Issue in Notepad++:

Console log in browser:

Memory dump:
microprofile-20210910-061508.html (2.2 MB)


Would it work if we just removed the escaped characters in the Microprofiler dump? So ScriptName\n becomes ScriptName


This would be an acceptable patch and wouldn’t affect memory dumps. Thanks for looking into this!


Any update on this, still occurs, I’m assuming you forgot about this? :sweat_smile:

Also when a fix is implemented could you post here so I can mark it as a solution.

1 Like

I put in a fix for client version 497. It takes a little while for fixes to get published because we’re very careful with changes - we try not to break things. :wink:
I’ll update you again when it should be live.


The fix is now active if you are running client version 497. Please let me know if there are any issues with it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.