Mesh importing with only one texture

When I import a mesh it only gives me one texture. A random one of rocks all over the mesh.

I’ve had this happen before and I fixed it by spending 16$ on a blender plugin to fix it. (it bakes all the textures into one). I tried using the same plugin in this case, but it doesn’t work for this mesh for some reason. They both have pretty much the same structure so I have no idea why this happens.

Any help is appreciated because i kinda rlly need this mesh :sob:

Its supposed to look like this

Meshes are limited to only one texture image. Your blender file uses multiple materials with different textures. Only way to avoid this would be baking the textures into 1 singular image, and importing that into roblox. There are plenty of tutorials on youtube for doing so.

1 Like

I said I tried this already and it didn’t work.
Its worked before now it hasnt.

I recommend actually reading a post first :+1:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.