Mesh importing with unnatural holes

Hey, so I’m trying to import this model of a bed with a blanket on top of it into roblox. The problem is that every time I import it, it has unnatural holes in it that were not in there in blender itself.

(In blender)

(In game)


I have tried recalculating the normals, flipping the normals, triangulating it, Merge by distance (0 vertices were removed), and limited dissolve (which only made it worse). Additionally, I have also tried to tick the double-sided option, which covers some of the holes but not all of them, meaning that it doesn’t fix the problem.

I honestly have no idea what to do, any help would be appreciated.

1 Like

Have you tried restarting Roblox Studio? :thinking:

1 Like

Yes, that didn’t really do anything.

1 Like

In blender, try enabling face orientation to see if certain faces are flipped.

If this is the case you can manually flip the normals by selecting the faces.

3 Likes

Hey, just tried this solution. It didn’t really do anything, as the mesh still looks the same when imported into Roblox.

1 Like

I’ve had the same issue happen to me a few minutes before this post, but I somehow managed to find a way around it.


Just as you, the mesh looked fine in Blender, but had unnatural holes in studio.
Blender (no holes):

Studio (with holes):

I went to Blender and re-exported it and checked off “Triangulated Mesh:”


That solved it for me, but I’m not too sure if it’ll work for you due to your very different mesh.
Good luck!
:wink:

2 Likes

Thank you so much. This solution completely worked.

The only question I have is if you applied the triangulate modifier before you ticked that option and uploaded it.

1 Like

I did not apply the triangulate modifier at all, I simply just ticked the option.

This should work for everyone! It’s because your mesh probably contained N-gons wich some software doesn’t acknowledge (Im not sure why). This also works when importing meshes to texture in procreate!

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.