Mesh is invisible

Hello, I’ve ran into a problem with my game. I’ve been trying to import some skinned mesh arms for a viewmodel and when i import them it’s just invisible!

Things I’ve tried: Flipping the normals, adding a solidify modifier

What I’m trying to import:

What I get:

All help will be appreciated.

1 Like

Alright so:
1- When importing the fbx make sure you did not tick the limit to “selected” box thing, and that you have mesh and bones highlighted in object types list.

2- Make sure normals aren’t flipped, you can check if everything is right by ticking orientation box under geometry.

If these don’t work then I’m unsure of what the issue may be.

1 Like

Sure, going to try this. Will get back to you if it worked or not.

Unfortantely, this did not work. The skinned mesh still stays invisible.

Something shows up in the output, so here.

it says the mesh is empty, are you sure its importing properlly?


I have to this error when I export my model and there is a mesh with no faces. You can also checked the selected objects tab as well.

the only way I got this issue to stop happening (and it still happens from time to time) is modeling with back face culling on. instead of modeling then enabling it after and recalculating normals/flipping

Fixed. Basically, the file had some meshes that were empties, and those empties were used to make the bones look different. Once I deleted those empties, it imported perfectly.

1 Like

That’s basically what I meant, you were exporting an empty mesh, no faces. Glad you figured it out!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.