Mesh lighting is wonk

Big blender noob here, so I tried optimizing a union in blender, and then mesh that came back has some weird lighting issues. Goal is to have optimized mesh look like the original union.

Original union without wonk light:

Optimized mesh

Here is that mesh with flat shading in blender.

What shading settings does your mesh have? It looks like you’ve applied Smooth Shading to this instead of Flat Shading - which would likely fix the issue.

If you don’t know how to change this, check the Blender wiki :slight_smile:

3 Likes

Another thing I’ve found is that Blender can take the weird information from Unions and try to fix it.

When Unions are made in Roblox they are generally pretty messy and have waaaay too many vertices. Go to Edit mode, select the Vertices tool, then go to Vertex > Merge Vertices and it’ll merge any vertices that are within whatever distance you specify in the pop-up in the bottom left corner of your screen. I usually select .003. This may help clean up extra Vertices and Faces which could be causing a few of the issues you see.
After I import Unions from Roblox I go in Edit mode and I usually select the Face tool, click A to select all, then go to the Mesh tool > Normals > Reset Vectors.
Also, use Flat Shading as @Aotrou said.

Try editing the mesh and doing these steps

Screen Shot 2021-05-18 at 2.12.37 PM
idk if flat lighting flat shading same thing

also @Blue_blockhead remove the shade smooth that should fix it

Could be multiple things, such as inverted normals, too many vertices in a face, smooth shading with no sharp edges, etc. Please screenshot it in edit mode so the wireframe is visible.
Until then, in edit mode select everything, press Alt+N and select Recalculate Outside.
And as others have said, using the same Alt+N keybind select Reset Vectors.

The problem is how you applied your shading on your mesh in blender, to fix this keep your mesh at smooth shading.

Navigate to Object Data Properties imageNormals, enable Auto Smooth and set the angle to 180°

You can either stop here any play with the angle property of the Auto Smooth setting and you might get the results you want really quickly (the angle represents the degrees at which edges will start to smooth shade, anything that falls above the specified angle will stay sharp shaded), or if you want a controlled way of sharp shading edges you can continue.

Enter Edit mode, select the edges of your mesh that you want to have sharp shading and press W (Default) to open Edge Context Menu and click on Mark Sharp

This will highlight marked edges in blue (Default) and will give sharp edges where marked. Flat faces fully marked in sharp edges will also mimic the “flat” shading effect, this method allows you to fully control which edges you want to have smooth shading and which edges you want sharp shading

Hope this helps!

1 Like

This worked best, many thanks.

1 Like