Mesh looks different in roblox when I import it from blender

I was making a mesh in blender and then I tried to put it in roblox studio, but when I did, it looked different

here’s what it looks like in blender:

and here’s what it looks like in roblox:

The weird thing is that when I look under it, it looks like how I intended it to look (I used the mirror modifier so idk what’s up with both sides):

If you didn’t figure out what’s the problem, the “imperfect” thing on the mesh (while in roblox) is that the middle part of it has a flat plane covering it. This doesn’t appear anywhere in the blender version of this mesh.

I’m new to 3D modelling in blender, so IDK how to fix it. Are there any solutions?

Yeah I get that error sometimes I haven’t figured what causes it or found an answer but if you edit the top faces to make it not all one face then when reimported should be fixed.

how do I do that? As I said, I’m still new to blender

So if you go into blender if you press tab it should take you into edit mode

When in edit mode you should see these icons to change to face select, vertices select etc.

Click the square and x to delete the errored face.

then click the first icon again and select the dots. Select medium sizes and f to make a new face.

Hopefully this is understandable fixes the issue

but the errored face only appears in roblox and not in blender

Its how the import from blender to roblox works out. It may not show but its there.

nevermind. What you said worked. Thanks

1 Like

This is likely an issue with face orientation (which way the face is pointing towards). To be able to detect this issue in the future, you need to enable face orientation. You can find this in the top right of your screen.


This now means that the faces that you will see (that are pointed towards you) will be blue, and the ones that are inverted (meaning you can’t see them, and they disappear in studio or look weird) will be red.

For example:

On the rib cage and some of the pelvic bone on this skeleton, the face orientation is red, meaning if it is exported into studio, you will not be able to see it. To fix this, you need to select the red areas and press ctrl + n or ctrl shift n. Try both of them to see if that fixes it.



Another fix that this will be able to help you with is by telling you if you have any double faces. In this case, the colour will be darker and more visible. For example:

Here you can see that there is a triangle face on top of the square face. Having extra faces like this will make your model look wrong in studio, so this needs to be fixed prior to exporting.

As @wellsway said, you can simply delete the extra face to fix the issue. But now you know how to easily identify where the problem is!