Mesh Render Fidelity Broken. Less than 10 studs aways

Roblox’s render fidelity is broken, I am standing four studs away from my mesh. The automatic setting does not work at all, even when I’m standing one stud from it. The meshes’ normals are 100% correct.

This is what the mesh is suppose to look like.

Again there is no problems with my normals. I checked if it’s also if the decimals were too small for Roblox and I scaled my model by ten. It did not fix it. This is entirely a problem with Roblox’s automatic render fidelity

It makes absolutely no sense for the mesh to start decimating at one stud.


What is your Studio graphics setting at?
I think max is 21 or 22.

I always had the highest settings on studio. I also use max when playing as a player too. The automatic settings still don’t work. At a distance of 0 it is still rendering at low quality.


1 Like

Set Mesh Detail Level to DistanceBased.

No clue why you have it set to Level 04, because that and the other ‘Level’ options simulate different LOD distances, the higher the number, the higher distance it simulates, 04 is the max distance/minimum LOD.

Reference Manual: