Meshes get Corrupted When Imported into Studio

When I try to import meshes into Studio from Blender, they get corrupted.
In Blender:

In Robox Studio:

Could someone please explain to me why it’s doing this to my meshes when I import them?
Thank you.


This might work go on blender go to your model and put it in edit mode and type shift n together. Then the model might work, I think it will work but not sure though. Or you might need to solidify the model.

It still is broken, sorry. I built the mesh from primitive shapes and I only used a mirror modifier and I made sure to apply it, I’m still not sure why this happens.

This most likely has to do with high triangle count, especially since it looks like you’re working with a lot of rounder surfaces. Try lowering the detail on your meshes in blender, then importing them back in.


I can’t do that, the client wanted this level of detail, and I’ve seen meshes with smoother surfaces in Studio.

At what scale did you import it in?

I’d say it was medium scale, you can get an idea from the picture.


If you want to keep that same level of detail, I’d suggest breaking it up into multiple meshes. ie. Make each spike a mesh, make the windows separate meshes, etc. What does blender say the triangle count is on this mesh?

Do you have unapplied modifiers? Like subdivision or any bevels. Also try importing the same mesh back into Blender to confirm. Roblox can’t corrupt meshes either it was already messed up or Blender is bugged.

Roblox doesn’t decimate when importing it just gives you a 10k+ tri pop up.

I don’t believe its related to the tris count considering Roblox will pop up an error if you have a high tris count.

I’ve had the same issue before when creating a model using 3D Builder so I don’t see how changing any unapplied modifiers in Blender or changing the scale in Blender is going to help.

Hey, did you find any solution to this? I experience the same issue right now… not from Blender, just exported and re-imported straight from Roblox Studio…

1 Like

This is a Roblox studio bug caused mostly when you apply “Shade smooth” to your mesh. Simply ignore it as it won’t apply in Roblox Launcher (Publish the game and play trough the website like any other game)


That has never happen to me I would just try reuploading the mesh to Roblox Studios!

I have shaded my stuff smooth and it has never happen to me.

Roblox simplifies things above 10k tris. Split up your model more or optimize it to be below 10k tris.

1 Like

Never said it always does but sometimes and sometimes works fine. I’ve it already atm. The mesh is normal when the game is played from site but bugged in studio. However after ShadeFlat its Ok. I just ignore it as it works anyway later on in the game it self.

1 Like

Hi there!

How many tris is your object? Do you have any modifiers applied to your object in blender?

The problem is with RenderFidelfity. The model should be fine in the game or once you play test in studio. Hope this helps!

Where do I find this setting ?