Meshes not importing in the right position

I’ve made a character that I want to import from blender into Roblox.

However when I try to import the mesh into the studio this happens,
The parts are all scattered around for some reason.
I am just importing these as normal meshes and not as a rig, so if anyone knows what I can do to fix this please tell me.

1 Like

Screen Shot 2022-08-17 at 7.40.40 PM
Do you have this setting turned on? If so, turn it off, maybe it wouldn’t scatter if you turn it off. I’m not sure if this would work, since I have never imported meshes from Blender before. (not very relevant, but I like the character design that you made)

Are you importing each peice as a separate mesh part? If so, make sure to say ‘Yes’ when asked if you want to import them at the origin position:

Yes, I am Importing it as separate meshes however, it never shows that Warning.

Also yes I have collisions turned off, even though that doesn’t change anything

Inside Blender if u want to Import it there are a few Settings can u see a Setting Named “…Group…” or something

1 Like