Meshes won't import in the same position

Hello, I’m having an issue with objects not importing in the same size nor position.

I’ve tried applying all transformations and setting the origin to 3d cursor, however the objects in blender still don’t come in Roblox right at all.

I set these meshes up in various parts at first, and imported them all at once. Then, I split them into two parts as groups, and it still wouldn’t import correctly :((

When imported into roblox studio
image

Some objects become missing as well. It’s really frustrating me and so annoying!

I really don’t wanna rescale every object because it’s a serious waste of time.

Please help :frowning:

Thanks for reading :))

Hm. That’s weird. Have you tried to doubleside the meshes in roblox studio??

I found a solution to the missing faces a while ago. My main concern is why the objects don’t be in the proper place, nor have the proper size. I’ve even tried scaling it down in blender, it’s seriously frustrating me.

are you importing with fbx? How to fix Scale of FBX model from Blender to Unity - 3D Tutorial 2019 - YouTube

1 Like

Thanks! Will check this out :))

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.