Meshpart Appearing Hollow! [Resolved!]

Okay, so I’ve never really had any issues with importing meshes into ROBLOX. However, recently, whenever I’ve uploaded meshparts - I keep having this issue in which it appears “hollow” from ALL angles, seen in the images below:
(Attempt at creating a scythe handle, however, it appears hollow! In Blender, it appears normal.)


There’s also this, in which is a WIP of a gun I was making.

I’ve tried using different methods of importing meshes into ROBLOX, such as special meshes, and I have attempted to shrink down sizes of the models in blender. I’m new to 3D modelling in Blender, and this issue certainly is strange, as I’ve never encountered this issue with my previous Blender models.

If someone could answer this, thank you so much! I’ve been searching for an answer everywhere. :smiley:


The face normals are probably inverted.

If you’re using Blender, you can use the Recalculate Normals button to fix it.


A little off topic but just saying but all that internal geometry for a gun made in blender shouldn’t be there - it adds on unnecessary tris to your model and makes it less clean overall.


Ctrl + N in edit mode after selecting faces individually to flip normals to face the opposite direction, or Recalculate Normals will do the trick here.


Thank you so much!

What is said above is correct: your normals are inverted. In blender, inverted faces generally are darker. This is fixed by selecting all and doing CTRL + N

If you open up the side panel in edit mode, and scroll down, you can display the direction of normals via blue tick marks like the following:

Furthermore, if it is important to note that a mesh face is view-able from only one side, this is why when the face is inverted you see the model as inside out. Which side is view-able is determined by the normal.

For your model, that means your gun barrel is going to look a bit odd since it appears you don’t have solid geometry. You’ll have a hole but if you look into the barrel, the gun will be invisible.

The solution? Fill the hole and extrude it backwards so you have a solid model with all normals facing outward.

Welcome to the world of 3d modelling, and good luck! If you haven’t already, I’d highly advice checking out BlenderGuru for some tutorials in the basics of Blender.


Future tip, a majority of the time the shading will look different and darker if the normals are facing the wrong way. Just remedy it with a quick ctrl + n, and you can use the backface culling option in the panel after press T, and scroll down, to view any backwards faces. Sometimes, you may have to manually flip normals, and you can select several and press W > Flip Normals.

Good Luck Blendering!

1 Like

I usually add a modifier to make it more thick even if it’s increased by only 0.01. Usually seems to fix it pretty easily for me.


And if someone is using Cinema 4D to build up meshes to flip up normals you use the functions menu and there should be an Align normals option.


The problem is that there is an inverted surface and a normal one.
the inverted surface is inside out and will appear hollow.
To fix this problem go to edit mode on Blender and pick the areas that are inverted and press ctrl+n.
good luck building that gun!

I’ve learnt a lot since then, and the problem has been long fixed for me- but thank you so much for contributing a response! ;D

If the problem has been fixed, please mark the fix as the solution to avoid confusion.


Thank you! It helped me a lot.