MeshPart Collision

Visually, my build looks stunning but one piece, in particular, the collision is way off. I’ve spent about an hour or so trying to figure out how to fix it to no avail.

Here’s what it looks like in blender.

Here’s what it looks like in studio with FileSettingsPhysicsShow Decomposition Geometry turned on.

As pictured above, the corners are filled where space should be present. Thanks in advance.


This has been a problem with meshes for a long time. For some reason, roblox uses a hitbox that uses only uses convex angles. Its talked about in other posts, and as far as I know, the only way to work around this is either by making a hitbox out of parts or making separate models for each of the problematic parts.

I don’t know if you want to do either of those, but good luck with your model.


Thanks for responding. Could you elaborate on this? I’m not quite sure I get what you mean.

I’m not very experienced with this, so it probably would be better to ask someone else. However, just make an outline of the mesh using parts.

Here’s a basic example of what I’m trying to say.


This was made super quickly, but the red part has cancollide on, while the telescope, the mesh, can’t be hit.

I hope this answered your question.

1 Like

Interesting. I would opt to do that if my mesh was basic. However, I’m not sure how to split a poly-metric shape into multiple parts that satisfy and correct the issue at hand.

1 Like

I’ve run into this problem a couple times as well. I never found a proper solution to fix this in studio besides uploading the object as separate meshes, I know it’s annoying but I would recommend doing this for more efficient workflow. Another positive is there is no need to worry about the collisions afterwards

1 Like

How does one go about dividing a mesh into separate meshes?


In my case I was using separate objects so it was very easy to split them up. I’m a blender noob myself so I’m not too sure how you would get around splitting that doorway up, the bisect tool might work I’m not certain, if not just do a bit of searching and I’m sure you’ll find a solution

1 Like

You have the mesh and you want to for example divide half of the mesh; select half of the mesh and press P and select the top option.

Like wise; if you want to merge different meshes, select the meshes you want and press CTRL + J. Refer to this in the future if you’re interested in all of the shortcuts.


Collision for meshparts is not working correctly. Here is a post I made about it and the community being well aware of the problem. It works for some simple shapes OK but is a big problem overall. Splitting your mesh would help sometimes but collision has problems with certain shapes no matter what. One option is to turn off collision on the meshpart and place invisible Roblox parts to give you collision boxes. In some cases it might even improve performance. Think jail bars or a wooden fence. 1 collision vs hundreds.