Meshpart collisions are broken

So after working on a chassis we stuck a meshpart car on it and test drove it the car will not stop bouncing around. The collisions are turned off yet the issue still happens setting the collision type to box or hull makes it 10x as bad. This has been going on for 2 days now with 4 different cars that we have tested.
https://gyazo.com/17cb40144c68a937ccb573d22d8da858.gif This is what happens.

Could you privately send us your model and repro steps? We will investigate. Thanks!

I will as soon as I can. Waiting on my coder to set it up so it does not need to send a module to the game since at the moment if I sent the game it would not load the module.

Also @Player1unknown can you do me a favor. Can you please go to File->Settings->Physics->ShowDecompositionGeometry (Check the box) and relaunch studio and repeat the test and post results here?

When you say:

This has been going on for 2 days now with 4 different cars that we have tested.

Do you mean that you’ve built new cars in the last few days and they are misbehaving, or that you’ve built these cars long time ago but they only started misbehaving in the last 2 days?

1 Like

Does the issue only occur in studio? If not, this belongs in client bugs.

By this, do you mean you set collision groups so that the wheels don’t collide with the car? (or the body has CanCollide off) If not, I think that’s something worth trying. As I think @Khanovich is getting at, the mesh of the car could be getting in the way of the wheels causing this behavior.

I had this happen to me with a basic car model I made before using regular roblox parts, and disabling collisions between the wheels and the body of the car using collision groups fixed it for me.

There is also a known bug that I am literally submitting a fix for as we speak: Basically when Convex Decomposition is calculated for large objects (larger than 50, by 50, by 50) there is a chance that the ConvexDecomp will randomly create a point OUTSIDE of the shape to include in the Convex Decomp. I noticed that some FBXs that I import from blender are pretty big.

If you’re relying on wheels imported as MeshParts to collide properly, this would be one of the issues.

I’ll have a fix for this shortly, but THIS thread needs more details about the bug report. Please follow the guidelines here:

EDIT: Didn’t mean for this to be a post aimed at you Extuls, just in general at this thread.

1 Like

Have you tried adjusting the density of the meshpart after changing the CollisionFidelity? Usually setting the CollisionFidelity to Hull or Box greatly increases the mass of the meshpart.

cars are only 2 days old and i have been meshing cars since they came out and never had this issue untill now.

yeah and if we have to seriously change that to density 10 every time we might as well quit trying to work on the game.

happens in studios and in game

we are not using meshwheels we are using spheres with fake mesh tires. And it is hard to explain the bug when it is literally just. Stick car body on chassis set cancollide = false and it acts like it is true.

1 Like

I checked all of that and it looked fine but ill do it again anyways.

Can you please send the repro model to me so that I can see the behavior. I cannot repro what you are referring to.

Also can you set the Density of the Meshparts to the lowest setting you can and see if it helps?

Density of meshparts is set to .001 or what ever the lowest setting is.

So I’ve been discussing the issue with OP in a private message. Essentially this seems to have nothing to do with Mesh Part collisions. So far it seems to be the model in the suspension of the car.

1 Like

That is a maybe we just spent the entire day doing what you suggested in private messages and still have the same issue.