MeshPart isn't moving or rotating in animation editor and effects the whole model when is moved or rotated

I wan’t to animate a gun on a model but it isn’t moving or being rotated.

The issue is that when I move the Gun Mesh or anything connected to it, it doesn’t move and instead effects everything else.

I looked in the dev forums for help and tried changing the order of the motor6ds but nothing worked

This is a video showing what I mean by not moving or rotating:

If anyone could help that would be epic.

hey i think is the rig or the model have a problem because your rig just have a one skeleton that attach to your custom arms or your model must be in the arm group

wait what do you mean by that?
i dont get it.

do you mean the rig editor plugin to show that skeleton thingy? if so that doesn’t effect anything.

1 Like

the rig of the skeleton you use right now it have one attacment on the model you want it

which attachment, can you name it?

the model on your character hand

I made a tutorial on gun animations but I made it so you can animate it inside of blender. I’m sure it works for the default Roblox Animation Plugin but I strongly suggest using blender to animate it so blender can smooth down the keyframes for you.

DevForums Post: Blender 2.8 View Model Tutorial (FPS ARMS)

I hope this helps you out! :slightly_smiling_face:


So, I decided to remake your entire model and see if it works for me and it works perfectly fine for me. I was able to rotate and move the gun correctly and everything came with it.


Here was what I did:


Heres me rigging the things up:

Rigging it up

That should help you a bit but if you have any questions on how some of these mechanics work, feel free to ask me and I will try my best to explain them in full details.

I hope this helps!

1 Like

Btw I did your blender thing (I though I was gonna have to manually rig everything in blender)

I have this problem again and I’m way to lazy to animate one idle animation on blender which is too hard for my small brain to use.