Meshpart not importing

Hello, I’m aesergtwa and I have a problem.

Whenever I try to import meshes (using bulk or meshpart) it does not show up. In bulk it is just stuck trying to rety the upload and when I try meshpart the meshpart stays the same and my mesh is not added. (I tried obj and fbx)

Screenshot 2021-08-28 192225

Can someone please help me fix this? I have read 2 articals on this and none of them have helped me.

Try restarting studio then reupload the mesh

this is what I would do …
make sure the mesh is under 10k tris
rename the mesh in Blender
export with new name
try to import again
good luck :slight_smile:

I have tried 5 times already and it does not seem to work.

My mesh is a beam so it is under 10k and I already exported it 7 times.

Then I don’t know what to do because I think this is a bug message @Bug-Support with the bug to report it. MAKE SURE TO USE THE PROPER FORMAT

Alright but I’ll keep this post open in case of a answer.

1 Like

It’s a beam? what sort of beam are we talking about here… a beam of light or a solid four sided beam? Also… it’s possible to make beams that have more than 10k tris.

Have you ever successfully imported a mesh because you say whenever you try to import meshes… not just this particular one. If you haven’t ever imported a single mesh something is wrong with either your method, studio or blender. … of these three I would say blender is least likely to be the issue. Most likely is the method you are using but since you have read two articles on this I imagine it’s probably a weird glitch in Studio.

If you have imported meshes before then there is something wonky about this mesh.

There must be a message that comes up from Studio when the mesh doesn’t import. what does studio say besides retry limit reached… Renaming the mesh would also reset the retry limit count I would think.

Also just in case you didn’t know… (sorry if you already know this) you can check the tri count (shown on the left ) by selecting the statistics option on the right.

I’m building classical you know wall panels?
So there are trim, lower panel, hand rail, upper panel, top trim (beam)
I’m trying to export the beam (top trim) it’s the only part I made in blender

And yes exporting other models is not working.

what is the error that you are getting?

Screenshot 2021-08-28 192225

Are there any modifiers on the mesh inside blender? cuz like are you 100% sure its under the tri-limit?

Also, I’ve had stuff not work before and I had to go in and move one of the verts slightly and then it worked. Roblox mesh moderation is kinda weird sometimes.

I meant why would you have to retry? There must be an error that came before the the retry limit met right?

I know next to nothing about Blender, but shouldn’t that be a .obj file type?

.obj or .fbx works. In my experience .fbx works better.

Sorry for the late response unexpected stuff came up.

I think you are correct, at this point donlaods and desktop are filled with fbx and obbj files but none of them work.

things that could be the issue … :

  1. Maybe you haven’t scaled it to fit in Studio. - when exporting you can either make sure the mesh is scaled appropriately in Blender, use the scale option in the export window (.01) or have studio scale it for you automatically with the import tool
  2. You maybe named it something that Roblox finds offensive.
  3. I have no other ideas…