Microprofiler force opening on startup in studio and client

Reproduction Steps
There are no direct links

System information
image



image

There are no reproduction files

I tried uninstalling Roblox Client and reinstalling, but the microprofiler still force-opens itself. I haven’t managed to find any way of not making it open upon startup. This bug has also persisted through several versions of Roblox Studio and Client.

EDIT:
Apparently you can prevent this behavior by opening the escape menu on client and setting it to off — so the bug is moreso that the microprofiler doesn’t respect ctrl + alt + F6 and any of the off-buttons on it:

Expected Behavior
I expect the microprofiler to stay closed until I decide to open it.

Actual Behavior
If you manage to reproduce the bug you’ll always get the microprofiler no matter what file you open using Roblox studio or what game you play on client.


Issue Area: Engine
Issue Type: Other
Impact: Low
Frequency: Constantly

4 Likes

Hey, sorry for the late response. I am unable to reproduce this issue on my side, is it still happening on yours?

The issue is still present, but no, it’s no longer happening for me, because I managed to disable the auto-open behavior.

When using the client’s escape menu to open the microprofiler, this issue will occur until you close the microprofiler the exact same way. The ctrl + alt + F6 shortcut, including the microprofiler UI’s off button are ignored when it comes to keeping the microprofiler closed upon startup for future sessions within studio and client.

I also manage another aspect of the issue whilst trying to reproduce the aforementioned problem:

In the video, I open the microprofiler with the escape menu, but if I use the microprofiler to close itself, or any shortcuts, its state will not be updated within the main menu, unless you explicitly use the main menu to close the microprofiler.

2 Likes

This also happened to me on the Roblox Mobile App on an iPad Air 4th Generation (64GB) and I tried reinstalling the app, and teh issue with the microprofiler was fixed. This was only a one-time issue tho. :slight_smile:

This has been happening to me for ~8 months. I reinstalled studio at one point and it went away, but it starts happening again after I open the profiler.

If you use Settings to turn the MP off and then Leave the experience, the MP should not be running the next time you run. Is that happening? That is by design because your settings are saved locally.

That works, I never tried turning it off in the settings because I turn it on using the F9 menu and I rarely have a reason to look at my settings. It’s confusing that the profiler has an “off” button that doesn’t turn it off, and that there’s a way to enable its setting from outside of settings.

Fair enough. So if settings remembers how you left it (via F9 menu) would that be satisfactory? Also do you typically Leave an experience or do you just kill it via the OS?

if settings remembers how you left it (via F9 menu) would that be satisfactory?

Yes that would

do you typically Leave an experience or do you just kill it via the OS?

I usually just kill it via the OS