Mobile players cant use UI

I have a strange issue, players on mobile absolutely cannot interact with UI buttons in any way. Hovering over them does not change the color, clicking them does nothing. I read as much as I could, and everything said to change my function from MouseButton1Click to Activated, and I did. It still wont let a player hover over the button or click it. I’ve tried on an actual phone, and I’ve tried on the studio emulator. The studio emulator allows you to hover over the button, until you click play, and then it stops. Any thoughts?



1 Like

This was an issue that I was facing previously.
I solved it by creating an invisible textbutton inside the real button and making the fake button slightly bigger that the actual one.

Then use MouseButton1Click for the fake one instead of the actual one.

Also make sure that the buttons have a ZIndex greater than the holder frames.

1 Like

That seems convoluted… There has to be some sort of solution anyone can find out, right? It’s a problem for all of my UI and I’m not hoping to go through every single one and every script just to fix it.

Hi, thanks for reporting this issue!

Just to clarify, is the issue that the MouseButton1Click and Activated signals aren’t firing for your TextButtons?
Or, are you look for visual feedback that the button was clicked (like the button should change color due to the AutoButtonColor property)?

Also has been working in the past and has recently broken?


Yes, I’m not OP but I have also experienced this issue before.
It happens on mobile for textbuttons and imagebuttons too pretty sure.

It may have something to do with a UIGradient being inside of the button.

@charlestonial or @emblazes if you have a chance, can you please share a repro file or game link that has this issue? That would helpful for debugging. Thanks!