ModalEnabled isn't making mobile controls vanish/appear

  1. Create a local script with the following code on any mobile device emulator:
The script
local UserInputService = game:GetService("UserInputService")
print(UserInputService.ModalEnabled) -- Prints false
wait(1)
UserInputService.ModalEnabled = true
print(UserInputService.ModalEnabled) -- Prints true yet the buttons are still visible.
  1. Test it in studios.

(RobloxDev link to is: https://www.robloxdev.com/api-reference/property/UserInputService/ModalEnabled)

I also reported this on the playerscripts thread but it’s good to have a dedicated thread about it New Player Scripts are coming (10.11.18), and how you can prepare

To fix this in your own game for now, you could manually hide the stick/jumpbutton :sick:

local touchgui = lp.PlayerGui:FindFirstChild'TouchGui'
if touchgui then
	touchgui.Enabled = false
end
1 Like

Thank you for the suggestion, as I’m sure others can use this as well!
I was planning on doing this anyways if I saw others were having issues.

Fix is live: LIVE NOW: Mobile Controls Toggle Fix for ModalEnabled + Upcoming Deprecation

2 Likes