Model is Sinks under the Part

Ello there (Has Been a Long Time i Guess.). I am writing this post out of frustration as this was my Last Option. I have this script.(idc if i revealed my Directory).

	local RaycastP =
	RaycastP.FilterType = Enum.RaycastFilterType.Whitelist
	RaycastP.FilterDescendantsInstances = {workspace:FindFirstChild(PlayerHoldingTool.Name.."'s_House").Floors}
	local ModelToPlace = Value.Value
	local RayCast = workspace:Raycast(Mouse.UnitRay.Origin,Mouse.UnitRay.Direction*1000,RaycastP)
	if RayCast then
		local Vector =,math.round(RayCast.Position.Y) + ModelToPlace.PrimaryPart.Size.Y/2,math.round(RayCast.Position.Z))

Everything works fine Except theres one tiny problem. You See there is a Part Under the Filter its Referring to and I Dunno how but the Part decides to sink.(i have tried the half part fix. didnt work.)

Images :-
The Part Sinks in the Ground. The Model:
the Weld is to Hold all parts together so if i move the primarypart all parts move with them. the click and script are just for test they dont do anything and the FireServer script just does this.

	if Request == "PlaceObject" then
		local Part = Arguments[1]:Clone();local Vector = Arguments[2];local C ="ClickDetector",Part.PrimaryPart);local LocalS = game.ReplicatedStorage.Tools.Tool.EditScript:Clone()
		LocalS.Parent = C
		LocalS.Disabled = false
		Part.PrimaryPart.Position = Vector
		Part.Parent = workspace:FindFirstChild(p.Name.."'s_House").Floors

Any Help will be Appreciated as i am Frustrated.

Solved by Changing the Parts Size upon which the Raycast was Ending on.

It was not Perfect like 1 so when i made the stud size 1 it started to work without the Half Fix as Apparently Unanchored Parts Align themselves on Y Axis Automatically.Sorry if Anyone is Writing a Response for this.