Model missing objects after cloning

I’m trying to clone a car model from a folder in ReplicatedStorage to the Workspace. When cloning it gets rid of all the meshes and scripts in the car.

Model in ReplicatedStorage:
Screen Shot 2023-07-23 at 2.48.40 PM

Model cloned in workspace, missing Body and Scripts
Screen Shot 2023-07-23 at 2.50.19 PM

I’ve tried looking for topics with the same issue but can’t find any.

Here’s the code that spawns the car.

local ev = game:GetService("ReplicatedStorage").Events.SpawnCar
local spawns = game.Workspace.CarDealerSpawns:GetChildren()
function spawnCar(player,s)
	local car = s:Clone()
	car.Parent = workspace
	local cfspawn = spawns[math.random(#spawns)]
	car:PivotTo(car:GetPivot() + cfspawn.Position)
1 Like

I’m having the same issue, a fix i used is using

local model = ReplicatedStorage:WaitForChild("modelname")

as it lets the objects load in


Just tried, slightly more stuff loaded, still missing meshes and scripts.

1 Like

make sure everything is anchored or welded together

1 Like

Same issue, weird thing is the cars spawn fine when in workspace on run.

1 Like

maybe try adding a wait before parenting to workspace

Did some testing and found that the issue happens after the position is changed.


Interesting. You sure they’re all Archivable?

Did you ever find more information on this? I’m having a similar issue, where I’m attempting to clone something from storage, and I’ve recently ran into a very strange issue where sometimes the parts within the model aren’t loading all of a sudden. Was wondering if there is a relation, or completely different…

1 Like