Model not moving to where I want it to

  1. What do you want to achieve? Keep it simple and clear!
    I cant seem to understand why my model wont move to my players humanoidrootpart, so i have tried to use moveto() aswell. here is a pic of my code, the model just goes to where it spawns.

    my script basically just drops tools from players backpacks.

  2. What is the issue? Include screenshots / videos if possible!
    It won’t move for some reason, I have tried CFrame and moveto(). Btw the model is all unanchored and all the parts are welded but they all are collidable.

  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    I have tried Devforum and YT.

Try replacing move to() with PivotTo() on the model.
I assume you can’t or don’t want to parent the clone into the player’s backpack.

still didnt work, idk why, I did everything u said, :frowning:

Ok, try putting :Clone() on the line where you declare the variable, local gunclone = …
And remove it from the following line so it reads gunclone.Parent = …
(Sorry on phone, difficult to type out code lines properly)

it doesnt work, i get this error

OMG it worked! i had to change something tho THANKSSS.