Model Tweening Issue

Hey Developers!

I’m currently trying to script a system that moves a car model to a designated part. However when I run the tween it is only moving the tweening part not the entire model. I’m not very experienced with tweening so I would appreciate some help.

Here is my code:

local TweenService = game:GetService("TweenService")

local part = game.Workspace.PurpleCar.tweenplace

local Goals = {
	Position = game.Workspace.waypoint.Position

local tweenInfo =


local T1 = TweenService:Create(part, tweenInfo, Goals)


Below is the tween part of the model which is moving but is not moving the actual car.

Here is how I have it layed out in the workspace, I’ve tried everything like welding it, anchoring certain parts etc.

Any help would really be appreciated. :heart:

Have you tried welding the model together and then tweening the PrimaryPart of the model?

(I know you welded it but the PrimaryPart is important)

EDIT: This link might help

I’ve already got the qPerfectionWeld script in so it’s welding the model, if I use the PrimaryPart as the tween part it just does flips and goes everywhere hence why I had another part over the car.

You need to apply the tween to the ModelRootPart instead of your tweening part otherwise it will only move that part.

You should weld the car’s parts to one part and tween it’s CFrame.
Keep in mind that all the parts need to be unanchored excluding the part you are tweening.
Hope this helps!

Even after doing this, it moves but it does like flips to get there, the cancollide for my tween part is off but it seems to push the tween part down resulting in the entire car to flip.

1 Like

Hey, I managed to fix it in the end. Thank you very much for everyone’s help, I really appreciate it. :heart:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.