Models are huge when importing them to roblox studio

Not sure if this is the right place to put this but whenever I upload a model from blender to studio it’s always huge in studio and I need to scale it down a ton. How do I stop this?

1 Like

Are you importing as an FBX or an OBJ? Are you using the asset manager, or smart mesh importer beta?

If you’re using the beta, you can see the dimensions of your file as Roblox reads it here,

If you’re importing as an FBX, I find myself having to turn down the scale in Blender when exporting here,

Usually I turn it down to 0.1 or 0.01(depends, but either or is usually pretty close to the original scale in Roblox)

Typically, you should only use the FBX export option on objects with bones(and some other niche use cases).

Hope some of this helps

1 Like

I do FBX so the texture uploads with the object itself, and thanks I’ll check out that scale thing, I’m pretty new to blender so I didn’t think about that.

When importing the mesh into Roblox Studio, Roblox will ask if you want the object to be scaled down, just press yes and it will be imported small. Also most of the time, most modelers start off by resizing their objects to a smaller size because they will import it into Roblox, you can also do that.