Moderation delay, too much data, servers down, or other?

I have been practising my blender workflow and adding to my model. Just as I feel I am making progress I get a bunch of errors that are gibberish to me but I suspect some element of human moderation at Roblox is bottlenecking.

I see this a lot when importing meshes (fbx files) into MeshParts:


That link is ancient, and can’t be copied, so here it is again:

There isn’t even the word “trouble” on the target of that redirect.

The thing is, my meshes imported fine for a while. I’m not experienced enough to certify this myself, so I go and review it in blender and attempt to import a fresh FBX. This must be sending a lot of traffic to Roblox. Possibly this is hobbling me?

My meshes show up just fine in Creator Dashboard ( They even have the correct UV mapping.

Each time I import an FBX it creates another entry in my creations, under meshes. I don’t recognise the ids here and when I try to use them I get an error:

19:19:48.197 MeshContentProvider failed to process because ‘could not fetch’ - Studio

That to me says one of three (or 4) things:

  1. Not enough manpower to moderate
  2. I’ve gone over my allowance with Roblox
  3. The service is down
  4. I’m a wrong’un (I did publish some modified models from Synty’s cityscape package earlier)

The meshes import in shape only, the colours are messed up. They look fine under my creations, online, though. The colours were all good until I tried adding a second texture image in my blend, a high-res seamless one, to be exported separately. This worked, but I could no longer update the original, small texture model.

I wish I could undo this, but it isn’t easy, and besides I feel like I could already be trying too hard and Roblox has just throttled me.

To illustrate, here is the slightly discoloured model, the blacks are still black but everything else is lilac:


Here is what it should like, and does, via the web portal:


It appears the same in my toolbox, at least in preview, but importing messes up the colours, as shown.

I just quit my Roblox software to see if it needed updating and it did not.

That lilac isn’t even in my pallete:


When I try plugging that into the texture ID it remains lilac and black.

Even the old models, that I had test imported earlier and then were coloured correctly, now import in this ugly 2 tone.

It’s got to be my images being moderating right? Each new mesh has pushed those same 7 pixels and while I have a few meshes showing up in the “creations” part of my toolbox I haven’t recorded any images today.

I tried importing the FBX into a new blender to get rid of the 2nd texture, same difference. I tried exporting as OBJ and importing to the MeshPart, no change.

After a bunch more YT videos I tried something else:

  1. From an experience published to my account (private published)
  2. Use an OBJ file from which explicitly had no material exported with it from blender
  3. The 2 above, I believe, are required to get the option of providing a texture file, e.x.p.l.i.c.i.t.l.y
  4. Give it the texture file I’ve already uploaded dozens of times and Roblox seems blind to
  5. Absolutely nothing changes, still just lilac and black :smiling_face_with_tear:

Very recent reference point:

Nobody has asked, but I will answer that the texture in debate use single pixels per color. I believed this could be causing bleeding together of, say, red and blue, into this lilac.


This happened before, IIRC. It would explain why Synty is using massive 8x8 and up blocks for each single color!

We need an option to turn interpolation off in our textures at import time. It appears it is off in the preview they offer into our assets which is a foolish inconsistency.

What has worked for me is using 2x2 blocks for each single color (living dangerously ikr!). I’d already used 4x4 per pixel when I had only 4 colors in my models (pavements). I don’t think it will kill performance having 16x16 or 8x8 textures. So that is exactly what I tried.



Publishing the experience to Roblox wasn’t required after all.

This doesn’t solve


but my workflow is at least restored so am happy.


Whenever importing your creations from Blender → Roblox, it requires the Mesh to be in either .obj or .fbx file! Once doing so, to import fully into your place at the Studio engine, you can use the new feature “3D Importer”/use “Bulk Import” in Asset Management (I personally would recommend the second option as you can import multiple assets such as Audios, Images, etc).

It is going to take a few seconds, but sure enough, it is going to appear fully. :slightly_smiling_face: Roblox moderation doesn’t take delay as from what I am aware, so it could have been a little bit of the status of the engine being down for a bit…

The issue here is aliasing of the texture. For a block oriented platform it should support pixel art better.

It makes no difference how I import it, this is just an illusion of choice, which I have tried, the 3D Importer at least.

I agree asset management would make sense in reducing duplication, but not so much as I learn the ropes and want direct-from-studio options.

1 Like

Roblox supports any type of art you upload (as long as it follows the community standards)… For example, whenever creating a Mesh with a gradient texture, it goes straightforward as to be possible to submit to your experience, however, the image asset takes some minutes to be fully approved as there are consistently others being sent to the platform, yet it can be approved.

If I import the FBX directly into a MeshPart I get immediate, accurate feedback.

I may have queried the moderation process, and I believe I can circumvent that importing direct to the MeshPart like this. That could explain why I get could not fetch errors because I uploaded so much rubbish for human mods to have to approve.

To further illustrate the root cause of my texturing problem, the image here is useful: Is it common/good practice to scale down faces in the UV Editor to fit into 1 pixel to have a normal diffuse? - Blender Stack Exchange

I’ve lost the original posts where I saw it mentioned, but people say to go for 16x16 as a minimum texture size, or 32x32. Whatever it was bigger than what I lived dangerously with.

I do NOT recommend using 2x2 pixels per color. Despite my original screenshots coming out well, the original renderings of my first attempt, using just 1 pixel per color also looked good for a number of hours.

Well, I can update you that my latest incarnation began to show browning of the red ropes. No biggy*, but I don’t want brown ropes, particularly not after approving the aesthetic of having red ropes. *I guess that’s why similar colors should belong next to each other in the map/palette.

Using 4x4 pixels per color and trying again. I’ll update if this goes wrong, but based on the diminished deviation from the first iteration I suspect 4x4 is ample. I won’t be trying 3x3, at least not with any power of 2 total texture I won’t.

Further to my solution, and the original motivation for posting here, I’ve located the correct link for troubleshooting mesh-parts:

3D Importer | Roblox Creator Documentation

It links to this very short official Troubleshooting video from just 2 months ago:

3D Importer: Troubleshooting - YouTube

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.