Module Script not seeing folder and string values[Solved]

My modulescript is not destroying the objects I want or setting the value of a string value to what I want. You can see here the two objects I want to destroy and the setting of the string to “Cutscene” :

Here is the result after the code has run and the objects are clearly not destroyed and the string value not changed :

These are the two lines of code that create the variables (I have checked that the variables are not nil when the code is running) :

MovementID = char.PlayerAttributes.Movement.ChangeID.ID

PlaceHolders = char.PlayerAttributes.Movement.PlaceHolders

What is more confusing is that the script runs over the code with no errors. Edit: Ignore that error as it is not linked to the problem.

Should it be changing to this? Shouldn’t it be MovementID.Value

1 Like

Oh I see I did not put .Value but I am still lost on why those two animations are not being destroyed.

No worry I sometimes even forget they have .Value when I work overtime.

1 Like

Actually you solved it thank you. The lack of …Value made it appear as if they were not being destroyed but since it was not changed it was actually remaking them after their destruction. Helps to have someone point it out though. I wasted like 2 hours on a simple mistake :rofl:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.