Modules not communicating in between eachother properly

Hey, so basically I have 3 modules. 1st one only holds a table, 2nd one writes and compares stuff in that table and the 3rd one is to do stuff based on the comparisons done by the 2nd module.
Problem is that when the 3rd module tries to use the comparing function in the 2nd module, it never works. However, using the exact same command in a simple script works, and no matter what testing I’ve done I haven’t found the reason for this exception.

Pertinent info:

Module 1:
module.plrdata = {[“Data”] = {“Data”, “Test”}} – would in theory point towards [“Data”][“Test”] in a
more complex table, prevents future problems with modifying stuff

Module 2:
data = require(script.Parent) – module 1
function module.Get(dataname)
–(uses a pcall to make sure the dataname is valid and points to a valid item in a table)

Module 3:
data = require(script.Parent.DataActions) – module 2
function module.DataTest()
print(data.Get(“Data”)) – prints false, which is for if a value isn’t found.

So, what do I do? Also I forgot how to format the text into lua if it’s even possible

Can’t help but feel like I’m overlooking something really obvious.

It works now. I took a 1 day break and decided to just create a new modulescript and now it just works. It uses very very similar code and I still don’t really understand what caused it not to work properly.

edit: I think I found something that might be related. It was for values with numbers, if you had, say, “Money1” and “Money2” it would look for Money1 in the list when it should’ve just been looking for Money, however this still doesn’t really explain why the script managed to run the code just fine.