Moon animator not saving movements

Whenever I go to pose my latest character, who has a snake-like body made up of 37 segments, when I go to save and quit out of the animator, and re-open the save, segment10 onwards is reset to its default state before posing.

Here is an example of a pose before quitting out.

Then after re-loading the save.

I’ve tried all of my other tricks that I would usually use for fixing a problem like this, such as: making sure all the segments don’t have double named parts, making sure all the joints aren’t double either, and even renaming 10 sections at a time with their own custom names, but to no avail.

From what I can see, it only occurs when using the Moon Animator, and not the classic RBX Animator that I usually use.


I have this too. Moon Animator is packed with useful things, that don’t export. Yesterday I wanted to move a player with CFrame, it worked in the Animator, but not in-game, then I checked the KeyframeSequence, and found out that there was no CFrame data exported.

In no keyframe the CFrame was saved

In Moon Animator this also happens with Subtitles, Markers and Effects

In this case, I was just trying to get the pose to save, so I could reload it later, so I hadn’t actually exported anything.

I really haven’t used Moon Animator before for posing or animating, just been using the classic animator for doing photography, using it to freeze my models in place for photos.