Motor HingeConstraint stops when it's turning

I’m working on a helicopter with a main (top) blade and a tail rotor. When you’re flying, both rotors should be spinning at full speed. They work using HingeConstraints with ActuatorType set to Motor, and blades are welded onto the grey cylinder part that actually spins.

The tail rotor seems to stop spinning whenever I turn the helicopter.

I can provide more context if necessary.

I think the reason the propeller looks to be slowing down is because the rotation of motors is close to the frame rate of your computer.

For example, image that you have a propeller spinning at exactly 5 rotations per second, and you had a camera that recorded at 5 frames per second. every frame that the camera would take would look the same because the propeller would spin right back in its original orientation as the camera was capturing frames, the video the camera produced would look like a still image.

the best thing for you to do is add some sort of blur effect to the propellers as our eyes perceive that as motion anyways.

I had a similar issue with my rotor blades…i just adjusted the angular velocity of the actuator motor and it started visually spinning better.

I know what you’re talking about and I’ve seen that exact thing when I record at a low framerate, like in this video:

However that’s definitely not what’s going on in this scenario. I recorded with a high fps specifically to avoid that issue. The footage isn’t great, so I can see why you would come to that conclusion based on what’s available, but you can test it for yourself here and see the issue isn’t FPS-related: I added the solution, so the issue isn’t present anymore Projectile Testing - Roblox

Try turning a lot while flying. Sometimes the tail rotor will stop completely flat, and take a few seconds to begin speeding up again.

Can you post a screenshot of the hinge properties please?

Attachments are in the pic in the original post

Have u tried a higher velocity?

Yes, same effect. thirtycharsmin

And the grey cylinder is noncollide?

I’m not sure how that’s related, but making it CanCollide=false worked. what do you think having collisions on does? Thanks anyway!

1 Like

Depending on where your attachments are, they can allow the parts to interfere or collide with each other… setting one part to noncollide allows it free movement. Glad it worked out for you.

I’m guessing the rotor was grinding up against the tail of the helicopter or something. I’ll remember that though

1 Like