Motor6D Weird Behavior, Root Part not clinging to the Humanoid

This happened after some updates, before it works fine, fortunately it happens only to one NPC in my game but this is

https://gyazo.com/2e5f004f30fea42097917c0d205a3b30

I tried to Motor6D it multiple times but it don’t work, only thing that it may work is when I try to weld the Root Part to Upper Torso instead of Lower Torso, but it will mess up the NPC’s animation.

2 Likes

There’s not enough information to solve this issue. Can you provide a reproduction or more information about the root part motors that connect something to the HumanoidRootPart. Additionally, can you provide the Humanoid’s hip height (property of the Humanoid object).

1 Like


This is the properties of HumanoidRootPart Connection to Lower Torso.

image

Properties of Humanoid Hip Height

It works good before with HipHeight 19 but after some updates I don’t know what update it is, it becomes like that

And this happens when I set it to -2.5 HipHeight, although the NPC can’t move because of that HipHeight.

Your humanoid’s HipHeight is off.

image

That is definitely not 11 studs worth and is what is incorrectly positioning your Humanoid’s height.

You also need to make sure your legs are not collidable.

Legs are not collidable, definitely not 11 studs but that’s what it looks like.

The reason why it’s like that is probably because it’s standing on top of that NPC, so it’s like HRP is seperated or not welded at all to LowerTorso.

This is probably a ROBLOX BUG and I can’t chat in the bug section.

It’s definitely not a Roblox bug but there is little more we can do to help because there’s a lot of guesswork involved without actually having a reproduction model. Is there any way you can just remove the MeshIds from the MeshParts and provide the model we can test?

npc.rbxm (164.1 KB)

This is the NPC file, it has an animation script in it.

What else I tried in here? Check their axis, the axis seems fine, front is front, top is top and left is left. When I tried to to flip the HumanoidRootPart, it just becomes like spiderman.

I don’t get that issue. I made sure I set the Humanoid RigType to R15 and I get this result.

Without animations at all, that will be like that. Trying moving the Y by -7 studs and back to 0 studs after a second, you’ll see it.

Doesn’t seem to happen. I let it fall when the game started and I even ran a MoveTo command in the CLI. It moves fine.

Video above.

Download the NPC again and load the animation “Testing” and upload it in Roblox then play the animation and you’ll see, because I tried to make it R15 and that’s already a solution I tried but it still didn’t fixed it.

I’m lost as to what you think this animation is supposed to do. If you shove the character parts under the ground, yeah, they HumanoidRootPart is going to compensate. Because the animation is playing, the parts won’t be brought along with it as the animation is overriding it.

Video below

This is expected and correct behavior.

Oh, it seems like my animation is the weird then.

That doesn’t make sense at all, because why does it work with other humanoids such as R15 or any other NPCs that I have?

I seemed to be able to touch the Y axis of other’s NPCs without it doing that weird behaviour. But in that model, I’m only freely able to touch X and Z.

It seems to multiple Y axis for some reason which is obviously unknown to me.

Or it’s probably because instead of LowerTorso MOVING, it’s actually moving the Humanoid Root Part INSTEAD.

Hello, I contacted Roblox about this and it seems like it’s a bug.

The reason why the animation looks weird when playing is because the name of the parts are like R15. (For example, UpperTorso is UpperTorso and LowerTorso is LowerTorso. I believe the bug is when HumanoidRootPart is rooted to something named LowerTorso if it’s not a real R15 rig.

1 Like