Motor6D won't function properly with animation when character is moving

Hey guys. Normally when I am animating tools I usually follow @Headstackk’s Animating Method because it works and functions exactly how I want it to…at least it used to. Recently, all of my tools have had this weird glitch happening where the BodyAttach part will not follow the animation playing whenever it is activated while the camera is moving. Here’s a video to hopefully explain it better:

As you can see in the video, the animation plays, however the BodyAttach part (Orange Cube near top of chair) never goes where it’s supposed to go until the character stops moving, or to better explain it, the user input is changed (meaning if the character is not moving at all, sometimes the animation will only play correctly if the character starts moving).

This method is pretty outdated I think, but I was wondering if there was some change to Motor6D’s behavior relating to animating, or if I’m somehow doing something wrong? The animations were working perfectly about a week or two ago.

If no one has a solution to fix this method, then if you guys could share your animating methods when it comes to tools that would be extremely helpful. Thanks!

Edit: Found out the problem. I was connecting the character Torso’s toolgrip on the server only and not also on the client which left a ton of delay. After connecting the motor6D on the client as well, it worked how it’s supposed to. It’s pretty exploitable but I can handle that.

It is more like the server delay rather than not functioning until the character is moving.

You can set the Motor6D’s part 1 on the client when firing the request to server, such that there won’t be a split second which the client has the tool but does not have it welded to a Motor6D.


Thank you for your input. I did suspect some delay on the server. I went back and read your tutorial on animating and realized I forgot to set the Motor6D’s part 1 to the torso on the client, which like you said, would leave some pretty significant delay. I took your suggestions and also added some other things and now it works perfectly. Thanks :happy2:.