Mouse stuck in "lookaround mode"


Sometimes when I test my game, the mouse is stuck in “lookaround mode”. This is expecially fatal when a GUI is active, so I can’t press the UI buttons (including the close button). There’s no way to get out of this other than completely leaving and restarting the experience.
So far, I’ve only encountered the problem in the Roblox Player, not in the built-in test run mode of the Studio. It also does not happen every time.

Does anybody know this problem, and how to solve it?

Thanks a lot!

1 Like

Do you mean the character is in first person? Also can I see the script?


u can go to starterplayer’s properties and click on cameramode and select it to lockfirstperson :smiley: about the ui just make a gui that maybe pops up when u click “H” but its a textbutton and it covers the whole screen and it has the property MODAL on :raised_hand_with_fingers_splayed:t2::fearful:

1 Like

If you wish to zoom out from first person wiithout using mouse, you can press I or O on your keyboard. (I for zooming in and O for zooming out). I’m not sure if this is what you asked for but hope it helps :smiley:

No. Then I would have written “first person”.
Sorry, I know “lookaround mode” is not a standard term. I really don’t know how to put it better.

First person in Roblox is really having the camera really close to the avatar. I know how to contol this (I and O keys).

What I mean is when moving the mouse only make you look around. There’s no mouse pointer, no possibility to klick something (object or button).

As for the script, there’s no special script associated with the occurance of this error. I can give you the script that activates the GUI:

local FGUI = script.Parent

local Trigger = game.Workspace.Ziel:WaitForChild("FinaleTrigger")
if Trigger then
	print ("Trigger gefunden")
	FGUI.Enabled = true

Thanks again

Hi, thanks for trying to help. Please read my reply to Interfield.

Would you be refering to shiftlock perhaps? Since that forces the mouse to be in the middle

I really tried everything, and I believe I tested the ShiftLock, too, but I’m not entirely sure. I’ll give it another try. Would be great if the solution is so simple.

To all of you:
As the error is not reproducealbe (i.e. it only occurs sometimes), testing will take some time.

Thanks again

This MODAL function sounds promising. I didn’t know it before, have to research it somewhat further, not really understand it yet.
Thanks a lot.

your welcome :smiley: a short explaination of MODAL is literally when its enabled it allows the mouse to move freely

I had the same issue with mouselock and fixed using the same MODAL method using a UI.

Does all the gui disappear? Does it happen when you press shift + p?

No, the GUI is still there, but the player can’t press any button, and therefore also can’t deactivate the GUI.

1 Like

I made a big invisible button with MODAL activated in the background of all GUI.
I still can’t say if this will prevent the error, as the error doesn’t occur regularly, as I said.
At least the button doesn’t cause any further problems.
For now, I’ll mark this as solution, hoping it will work out.
Thanks again to all of you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.