MouseButton1Click not firing

Tapping on GUI buttons appears to not work for some players today in Welcome to Bloxburg.

Haven’t been able to reproduce this myself, but it appears to happen sometimes for players using iOS devices. Tapping affected buttons seems to fire MouseButton1Down and MouseButton1Up, but not MouseButton1Click like it used to.

Will update with more information…

Reports

https://twitter.com/KooKoo_Da_Biter/status/1037115588500496395

7 Likes

I always thought that MouseButton1Click didn’t fire on mobile? I’ve been having this issue since last year.

Not that I know of. MouseButton1Click has been working reliably on mobile before the recent update.

This only affects a few devices, and some buttons correctly fire the event while others do not.

Is the button set to active? Is selectable set to true? Is selected set to false? Is modal set to false?

That’s strange that it’s happening to only a few buttons. Is it the same buttons or random per session?

Buttons are Active and Selectable.

Non-working buttons are consistent between sessions. Most buttons that aren’t working are children of ScrollingFrames.

2 Likes

I will look into this. Btw does it seem to work if you use Activated event instead? This is the preferred way of listening to clicks with a mouse and taps with a touch. Eventually we will deprecate MouseButton1Click in favor of Activated

1 Like

Great! :smiley:

Not able to test that right now, but will definitely look into using Activated in the future.

This should be fixed now. Let me know if you still see this. I still advise to moving to activated event, generally this works better.

1 Like

Seem to have players complaining about this now on mobile, buttons no longer seem to work anywhere, this seemed to start occuring within the last week, as I just re-opened my game with about a week’s break.

Seems to only occur for mobile/tablet players, like Coeptus stated.

If it is the case that I have to use activate (which it seems like it will be if MouseButton1Click will be deprecated), is there a quick way to find all scripts that use this and replace it?

Because I must have like 100 gui buttons that people can click in my game, so RIP.

Edit: After a long process I’ve added TouchTap events to every button in the game, rip my brain. Hope it works.

Further edit: Oddly enough, I think all buttons that aren’t within frames in general seem to still work?

Even further edit: I have replaced all MouseButton1Click with Activated, I’ll report back as to whether it worked.

Swapped everything to ‘activate’, it seems that this does not work either, not sure what’s going on.

I’ll try making a game with buttons, and have one in a frame and one not to see if I can reproduce this.

Edit: Doesn’t seem to be frames that are the issue, just made a game to test the theory. I have no idea what is going on.

If you want a link to a game where it occurs here is my own:

Sadly due to this I had to remove a lot of robux from mobile sponsors, which was a pain - luckily my players can’t buy anything (or unluckily however u look at it lol), so I suppose at least I don’t have a lot of people demanding refunds, unlike Coeptus may wake up to.

I don’t know if you have the authority to check the code or not, or whether this helps.

1 Like

Was this ever fixed? I am still having this issue, but not on mobile, on PC. I would assume its the same issue.

Buttons fire fine when in a frame, but when in a scrolling frame, they are non responsive. Tried MouseButton1Click and Activated, with neither working.

1 Like

I’m also wondering about this. I tried MouseButton1Down, MouseButton1Click and Activated, and only MouseButton1Down is being recognized on mobile. Is this by design or a bug?

Edit: Fixed through this.

A post was merged into an existing topic: Off-topic and bump posts